Objekte verschieben ist sehr langsam

Forum rules
Post Reply [phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
LHille
Posts: 3
Joined: Tue Apr 24, 2012 7:47 pm
Contact:

Objekte verschieben ist sehr langsam

Post by LHille » Tue Apr 24, 2012 8:14 pm

Guten Abend und Hallo an alle;
Ich begrüße erst einmal alle hier im Forum.

dfm2html benutze ich nun schon ca. 2 Jahre bin sehr gut zufrieden damit und hatte auch keine größeren Probleme. -bis jetzt

ab irgendeinem Zeitpunkt :?: , habe ich das Problem, dass sich Objekte , Bilder oder Textfelder, nur noch ganz langsam verschieben lassen.
Ich arbeite überwiegend mit der Tastatur
Wenn ich mit der Maus ein Objekt verschiebe dauert es auch ziemlich lange (ca. 2-3Sek) bis das Objekt an die neue Stelle springt.

Ein Arbeiten ist so nicht mehr gut möglich, da alles unendlich lange dauert.

Vielleicht hat ja einer hier im Forum eine Idee woran das liegen könnte.

PS. eine EMail an support@dfm2html.com blieb leider unbeantwortet :cry:
Gruß
LHille

reuterr
Posts: 253
Joined: Sat Jul 24, 2010 9:59 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Objekte verschieben ist sehr langsam

Post by reuterr » Tue Apr 24, 2012 9:07 pm

Hallo,
mit DFM2HTML hat das garantiert nichts zu tun. Hast du dieses Symptom auch in einem Bildbearbeitungsprogramm? Wie verhalten sich Office-Anwendungen? Da belegt wohl irgendwas deinen Arbeitsspeicher, oder im Hintergrund läuft ein rechenaufwendiges Programm.
Schau mal mittels Task-Manager, ob du da was ausmachst. (Alt Gr + Strg + Entf öffnet diesen)
Gegebenfalls diesen Prozess, wenn er dir was sagt und ganz sicher keine Systemroutine ist, beenden.
Vielleicht - das ist nicht so wahrscheinlich, aber zumindest überprüfenswert - ist dein System auch völlig fragmentiert: Also starte mal eine Defrag.
Bei dieser Gelegenheit auch prüfen wie voll deine C-Partition ist. (Start - Arbeitsplatz - Rechtsklick auf Laufwerk:C - Eigenschaften - Extras)
U.U. musst du 2-3 Programme löschen - zumindest testweise - um Platz zu schaffen.
Papierkorb leeren, mit einem CleanerProgramm alle überflüssigen Dateien löschen ( EasyCleaner ist freeware und dafür gut geeignet)
Wenn du nur in den Ruhezustand runterfährst, wird nach einer Weile das System u.U. auch langsam - Also mal einen Neustart ausführen.
Hast du schon lange keinen System-Sicherheits-Update mehr zu Ende laufen lassen, mach auch das mal.
Auch eine Firewall kann sowas verursachen, wenn man die Prüfroutinen immer durch runterfahren unterbricht.
Das mag jetzt blöd klingen, aber ich habe sowas schon alles erlebt....
Je nachdem, was für einen Rechner du hast, kannst du hören oder an einer LED erkennen, ob da auf deiner HDD (Laufwerk) der Teufel los ist.
Wenn ja, mache erstmal gar nichts und warte ab, bis er fast ohne jede Aktivität ist. Alle Anwendungen schließen.
Das kann einige Zeit dauern, wenn da sehr viel Updates "im Rohr" sind.
Glückauf dann also und melde dich wieder, wenn das alles nix war.
Gruß

LHille
Posts: 3
Joined: Tue Apr 24, 2012 7:47 pm
Contact:

Re: Objekte verschieben ist sehr langsam

Post by LHille » Wed Apr 25, 2012 6:08 pm

Hallo,
danke für Deine schnelle und ausführliche Antwort.
ich vergaß zu erwähnen, dass ich in Sachen EDV eigentlich recht bewandert bin (soll kein Eigenlob sein)
und natürlich all Deine Tipps auch schon selbst überprüft hatte (sorry)

Mir ist allerdings aufgefallen, dass sich die CPU Auslastung auf bis zu 80% hochschaukelt während ich ein Objekt mit der Tastatur verschiebe.
Hat das Objekt seine Pos. erreicht, ist die Auslastung wieder bei normalen 1-3%
Ich habe dann einmal einen Test mit einer neuen Vorlage aus dem Workshop gemacht und siehe da, das Problem tritt nicht auf.
(hätte ich ja auch schon beim Ersten mal sagen können) :roll:

Ich denke, dass es doch irgendwie an meinen dfm Dateien liegt.
Ich betreue 2 Websites und habe bei beiden dfm Dateien das Problem.
(aber wie schon gesagt nicht von Anfang an)

Wenn du noch mehr Infos brauchst, lass es mich wissen.
Gruß
LHille

reuterr
Posts: 253
Joined: Sat Jul 24, 2010 9:59 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Objekte verschieben ist sehr langsam

Post by reuterr » Thu Apr 26, 2012 9:31 am

Hm, dasja'n Ding....
Wie bist du denn organisiert? Hast du einen Projektordner, in dem alle verwendeten Dateien abgelegt sind?
Ich kann mir vorstellen, dass Viele z.B. die verwendeten Dateien und Bilder irgendwo auf ihrem Rechner liegen haben und sich der Editor jedesmal von "sonst wo her" die Dateien reinladen muss.
Vielleicht kostet das auch Zeit, wenn es sich um viele Bilder handelt.
Ich habe immer alle relevanten Dateien in Unterordnern im Haupt(Projekt-)ordner - das hat auch den Vorteil, dass man Letzteren sonstwohin kopieren oder verschieben kann, ohne die Bilder oder "file"-Objekte neu auswählen zu müssen.
Ist wahrscheinlich wieder 'ne Binsenweisheit für dich, aber zur Sicherheit.........
Verwendest du vielleicht sehr große Bilder mehrmals in verschiedenen Größen für deine Projekte? Der Editor muss so womöglich zeitaufwendig umrechnen. (ein Originalbild von z. B. 7200px x 4800px in (360 x 240) und (720 x 480) und (240 x 160) etc). Ich bringe die Bilder in einem Bildbearbeitungsprogramm meist auf gewünschte Größe, bevor ich sie im Editor selektiere.
Welche Extensions haben deine Bilder? Der Automatismus erstellt meist pngs wenn jpegs völlig ausreichend wären......... Das kannst du ja explizit angeben.

Wenn alle Stricke reißen, könntest du mir auch mal die ganze Chose zippen und an info@ichrr.de schicken.
Du kannst/solltest dann allerdings(zu deiner Beruhigung - ich könnte ja auch ein Arsch sein) den FTP-Pfad in der dfm-file vorher löschen.
Wäre doch interessant zu wissen, ob sich das Symptom auf einem anderen Rechner genau so darstellt.
Gruß

LHille
Posts: 3
Joined: Tue Apr 24, 2012 7:47 pm
Contact:

Re: Objekte verschieben ist sehr langsam

Post by LHille » Thu Apr 26, 2012 12:12 pm

Tach,
ich glaube natürlich nicht dass Du ein "Arsch" bist, sonst hättest Du dir bestimmt
nicht so viele Gedanken um mein Problem gemacht. erst mal Danke dafür!

Ich habe das Ganze heute Morgen mal auf einem anderen Rechner probiert -NEGATIV-
Dann habe ich mal, bis auf die erste Seite, alle anderen Seiten und Bilder gelöscht.
Selbst dann geht es nicht.
Das hat mich dann doch etwas stutzig gemacht und mir kam folgende Idee. :idea:
Ich habe ALLES markiert und ab in die Zwischenablage.
Dann eine neues leeres Dokument geöffnet und alles wieder eingefügt.
Was soll ich sagen, alles ist wieder wunderbar schnell :!: :!:
Nur noch die Seiteneinstellung (Pfade, FTP usw.) neu eingeben und alles ist OK :)

nochmal vielen Dank für Deine "Anteilnahme" ;)
Gruß
LHille

reuterr
Posts: 253
Joined: Sat Jul 24, 2010 9:59 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Objekte verschieben ist sehr langsam

Post by reuterr » Thu Apr 26, 2012 3:25 pm

Waaas? Ohne Worte.
Sowas nannten wir früher - bei "Big Blue" ;) - "Fehler verschwand bei Fehlersuche!"
Weitermachen.

laguna
Posts: 1
Joined: Thu May 24, 2012 1:57 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Objekte verschieben ist sehr langsam

Post by laguna » Thu May 24, 2012 1:59 pm

Mir haben deine Tipps schon weitergeholfen. Wobei mir Fehler eliminieren durch Fehler suche lieber wäre :D
Grüße und danke nochmal!

reuterr
Posts: 253
Joined: Sat Jul 24, 2010 9:59 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Objekte verschieben ist sehr langsam

Post by reuterr » Thu May 24, 2012 3:54 pm

Tja, DAS ist allemal die bessere Variante, aber die Wege des Herrn sind - so sagt man ja in gewissen Institutionen - manchmal seltsam....
Freut mich jedenfalls, dass ich Manchen hier schon weiterhelfen konnte.
Gruß

Post Reply
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Return to “German Forum”